• › Witaj Gościu
  • Jesteś niezalogowany (
  • Zaloguj 
  •  lub  

Logo


Strefa czasowa: UTC + 1




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 
Autor Wiadomość
 Tytuł: Flash w PHP - niby wszystko OK a jednak...
PostNapisane: Cz wrz 23, 2010 6:51 am 
Offline

Dołączył(a): Cz wrz 23, 2010 6:18 am
Posty: 2
Witam!

Mam niewielki problem z playerem plikow muzycznych wykonanym w FLASH wstawiony do strony wykonanej w php.
Oto kod zawarty na podstronie demo.php na którym znajduje sie player:
Kod:
<div id="flashPlayer">
  This text will be replaced by the flash music player.
</div>
<script>
   var so = new SWFObject("playerMultipleList.swf", "mymovie", "465", "200", "7", "#FFFFFF"); 
   so.addVariable("autoPlay","no")
   so.addVariable("playlistPath","playlist.xml")
   so.write("flashPlayer");
</script>


Sam player jest to plik
Cytuj:
playerMultipleList.swf

plik:
Cytuj:
playlist.xml
jest play listą, tam znajduje sie spis utworów i ścieżka do nich.
Strona demo.php jest wczytywana do pliku index.php. W sekcji <head> pliku index znajduje sie odwolanie do skryptów:
Kod:
<head>
...
<script language="javascript">AC_FL_RunContent = 0;</script>
<script src="AC_RunActiveContent.js" language="javascript"></script>
<script src="inc/swfobject.js" language="javascript"></script>
...
</head>

Pliki swf i xml oraz swfobject.js sa w tym samym katalogu co demo.php,
pozostale skrypty w katalogu głównym tak jak index.
Dodam jeszcze, że zasadniczo ślad po wstawionym playerze jest na stronie w postaci białego prostokątu, a po kliknieciu prawym klawiszem myszy wyswietla sie podmenu z informacją:
Cytuj:
Film niewczytany...

Myslę ze dosyc szczegolowo opisalem problem.
Jezeli ktos zna sposob rozwiazania to prosze o podpowiedz.

P.S. Problem pojawia sie zarowno pod IE jaki FF dodam ze ustawienia przegladarek sa ustawione pod katem wyswietlania Java, animacji itd.
Dziekuje
pozdrawiam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Flash w PHP - niby wszystko OK a jednak...
PostNapisane: Wt wrz 28, 2010 1:08 pm 
Offline

Dołączył(a): Wt wrz 28, 2010 12:59 pm
Posty: 1
masz problem ze ścieżkami, sprawdź czy dobrze linkujesz do playerMultipleList.swf w
var so = new SWFObject("playerMultipleList.swf", "mymovie", "465", "200", "7", "#FFFFFF");

jesli playlist.xml nie jest w glownym katalogu to raczej powinienes go podawac katalog/playlist.xml
sugeruje zainstalowanie firebuga i podglądnięcie w nim ładowanych plików (zakładka sieć) na czerwono zgłosi ci się czego mu brakuje

_________________
Hotele w Krakowie - NajlepszeMiejsce.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: Flash w PHP - niby wszystko OK a jednak...
PostNapisane: Pt paź 01, 2010 11:52 am 
Offline

Dołączył(a): Cz wrz 23, 2010 6:18 am
Posty: 2
Problem rozwiązany, źle podlinkowne pliki.
Temat do zamknięcia


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 3 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Skocz do:  
cron

Polecamy












Powered by phpBB
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
Not able to open ./cache/data_global.php